Calix Community  
 
Reply
Calix Certified
Posts: 47
Registered: ‎02-11-2010
0

Flow Analyzer classic won't run. Java certificate error?

[ Edited ]

I had to update java when I installed the newest version of CMS and now Flow Analyzer is broke.

 

I am getting a certificate error when I try to run the .jnlp file that usually launched my Flow Analyzer program. If I try to launch it from the url it says certificate error and says I don't have JRE installed. I do have JRE installed. I've uninstalled it and reinstalled it a dozen times trying to get it to work. in the web browser (IE) it also says certificate error. When I try to launch the .jnlp file I get this error. I've included a screen shot. 

 

I installed an old version of java. Java 7 and Flow Analzyer lunches. So is FA not compatible with the newest version of Java? Where can I get the lastest version of Java that FA works with?

Contributor
Posts: 91
Registered: ‎09-21-2015
0

Re: Flow Analyzer classic won't run. Java certificate error?

@averwo

 

had to resolve this issue for another app recently. I discovered that to make the FA Java client work again, I had to remove the MD5 algorithm from the unsupported encryption algorithm list, which the newest update added it to that list.

My procedure:


Edit java.security file in the “C:\Program Files (x86)\Java\jre1.8.0_131\lib\security” folder. (this must be done as an Administrator)

 

Current: “jdk.jar.disabledAlgorithms=MD2, MD5, RSA keySize < 1024”

Recommened: “jdk.jar.disabledAlgorithms=MD2, RSA keySize < 1024”

 

This worked for me. RMMV.

 

Java.Security Modification.PNG

 

 

On a side note, how do you attach a file?? I could only figure out how to insert an image.